Burn ISO to USB via Mac Terminal

Mindwatering Incorporated

Author: Tripp W Black

Created: 11/13 at 05:33 PM

 

Category:
OS X Tips & Hints
Utilities

Task:
Create bootable USB stick of ISO.


Example Solution w/Ubuntu 24 Desktop:
1. Locate USB Stick of 6 GB or more

2. Using Disk Utility, format the disk as MS-DOS with GUID-Partition.
a. Applications --> Utilities --> Disk Utility

b. Insert the USB stick
<wait>

c. Right click the USB drive just added, and choose Erase.
WARNING: Make sure that what you have selected is the USB stick and not some other removal drive (e.g. your Time Machine or other such local backup storage).
- Select MS-DOS
- Select (default) GUID Partition Map
- Click Erase
<wait>

After disk is erased, it will be automated on the desktop/in finder.

3. Open up Terminal and burn the ISO to the USB stick
a. Applications --> Utilities --> Terminal

b. Become root:
$ sudo su

c. Get the device number for the USB sitck:
# diskutil list
<sample output below>
. . .
/dev/disk11 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *15.7 GB disk11
1: Windows_FAT_32 U 15.7 GB disk11s1
. . .

Verify the size of the USB (e.g. 16 GB USB for us)

d. Unmount the disk and burn the file
# diskutil unmountDisk /dev/disk11
<view confirmation: Unmount of all volumes on disk11 was successful>

e. Finally, burn the file using the "raw" disk option, which is faster, but this will still take a while
# dd if=ubuntu-24.04.1-desktop-amd64.iso of=/dev/rdisk11 bs=1m
<wait 5 to 15 minutes or so - see example output below>
5915+1 records in
5915+1 records out
6203355136 bytes transferred in 671.925829 secs (9232202 bytes/sec)

f. Verify with another list:
# diskutil list
<sample output below - the disk is only 5.9 GB, the rest of the 16 GB is hidden free space>
. . .
/dev/disk11 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *15.7 GB disk11
1: Microsoft Basic Data 6.2 GB disk11s1
2: EFI ESP 5.2 MB disk11s2
3: Microsoft Basic Data 307.2 KB disk11s3
(free space) 9.5 GB -




previous page